redistribution EIGRP with VRF

Moderator: mike

Post Reply
dimelo
Posts: 14
Joined: Tue Aug 22, 2017 12:40 am
Location: Brazil

redistribution EIGRP with VRF

Post by dimelo » Thu Feb 14, 2019 11:06 am

the redistribute configuration of the static routes in the IFDVO to the IFCTM is not working, does anyone have any suggestions?

CONFIG IFCTM

!
interface Ethernet0/0
no ip address
!
interface Ethernet0/0.804
description SWDVO - BANESTES - VLAN 804
encapsulation dot1Q 804
ip vrf forwarding IF_BANESTES
ip address 172.50.0.56 255.255.255.240
standby 1 ip 172.50.0.62
standby 1 priority 50
standby 1 preempt
!
interface Ethernet0/1
ip vrf forwarding IF_BANESTES
ip address 10.228.28.30 255.255.255.252
!
router eigrp 100
!
address-family ipv4 vrf IF_BANESTES autonomous-system 100
network 172.50.0.48 0.0.0.15
passive-interface default
no passive-interface Ethernet0/0.804
exit-address-family
!
ip route vrf IF_BANESTES 0.0.0.0 0.0.0.0 172.50.0.49 name default-route-to-firewall
ip route vrf IF_BANESTES 172.16.254.87 255.255.255.255 10.228.28.29 200 name Autoriz_BANESTES
ip route vrf IF_BANESTES 172.16.254.88 255.255.255.255 10.228.28.29 200 name Autoriz_BANESTES
ip route vrf IF_BANESTES 172.16.254.180 255.255.255.255 10.228.28.29 200 name Autoriz_BANESTES
ip route vrf IF_BANESTES 172.16.254.184 255.255.255.255 10.228.28.29 200 name Autoriz_BANESTES
!




CONFIG IFDVO


!
interface Ethernet0/0
no ip address
!
interface Ethernet0/0.804
description SWDVO - BANESTES - VLAN 804
encapsulation dot1Q 804
ip vrf forwarding IF_BANESTES
ip address 172.50.0.55 255.255.255.240
standby 1 ip 172.50.0.62
standby 1 preempt
!
interface Ethernet0/1
ip vrf forwarding IF_BANESTES
ip address 10.224.240.1 255.255.255.252
!
router eigrp 100
!
address-family ipv4 vrf IF_BANESTES autonomous-system 100
redistribute static
network 172.50.0.48 0.0.0.15
passive-interface default
no passive-interface Ethernet0/0.804
exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route vrf IF_BANESTES 0.0.0.0 0.0.0.0 172.50.0.49 name default-route-to-firewall
ip route vrf IF_BANESTES 172.16.254.87 255.255.255.255 10.224.240.2 name Autoriz_BANESTES
ip route vrf IF_BANESTES 172.16.254.88 255.255.255.255 10.224.240.2 name Autoriz_BANESTES
ip route vrf IF_BANESTES 172.16.254.180 255.255.255.255 10.224.240.2 name Autoriz_BANESTES
ip route vrf IF_BANESTES 172.16.254.184 255.255.255.255 10.224.240.2 name Autoriz_BANESTES
!
You do not have the required permissions to view the files attached to this post.

Uldis (UD)
Posts: 2103
Joined: Wed Mar 15, 2017 4:44 pm
Location: London
Contact:

Re: redistribution EIGRP with VRF

Post by Uldis (UD) » Thu Feb 14, 2019 9:44 pm

Try it on vIOS or CSR routers

User avatar
NitrousOxyde
Posts: 47
Joined: Sun Oct 15, 2017 4:54 pm
Location: Baku

Re: redistribution EIGRP with VRF

Post by NitrousOxyde » Sat Feb 23, 2019 7:53 am

Config looks correct

Could you paste output of EIGRP topology?
CCIE R&S #59198

sam1925
Posts: 1
Joined: Mon Feb 25, 2019 5:33 pm

Re: redistribution EIGRP with VRF

Post by sam1925 » Mon Feb 25, 2019 6:02 pm

no default-metric?

User avatar
NitrousOxyde
Posts: 47
Joined: Sun Oct 15, 2017 4:54 pm
Location: Baku

Re: redistribution EIGRP with VRF

Post by NitrousOxyde » Fri Mar 01, 2019 3:37 am

sam1925 wrote:
Mon Feb 25, 2019 6:02 pm
no default-metric?
Shouldn't be an issue when redistributing static routes
CCIE R&S #59198

Post Reply