Page 1 of 1

redistribution EIGRP with VRF

Posted: Thu Feb 14, 2019 11:06 am
by dimelo
the redistribute configuration of the static routes in the IFDVO to the IFCTM is not working, does anyone have any suggestions?

CONFIG IFCTM

!
interface Ethernet0/0
no ip address
!
interface Ethernet0/0.804
description SWDVO - BANESTES - VLAN 804
encapsulation dot1Q 804
ip vrf forwarding IF_BANESTES
ip address 172.50.0.56 255.255.255.240
standby 1 ip 172.50.0.62
standby 1 priority 50
standby 1 preempt
!
interface Ethernet0/1
ip vrf forwarding IF_BANESTES
ip address 10.228.28.30 255.255.255.252
!
router eigrp 100
!
address-family ipv4 vrf IF_BANESTES autonomous-system 100
network 172.50.0.48 0.0.0.15
passive-interface default
no passive-interface Ethernet0/0.804
exit-address-family
!
ip route vrf IF_BANESTES 0.0.0.0 0.0.0.0 172.50.0.49 name default-route-to-firewall
ip route vrf IF_BANESTES 172.16.254.87 255.255.255.255 10.228.28.29 200 name Autoriz_BANESTES
ip route vrf IF_BANESTES 172.16.254.88 255.255.255.255 10.228.28.29 200 name Autoriz_BANESTES
ip route vrf IF_BANESTES 172.16.254.180 255.255.255.255 10.228.28.29 200 name Autoriz_BANESTES
ip route vrf IF_BANESTES 172.16.254.184 255.255.255.255 10.228.28.29 200 name Autoriz_BANESTES
!




CONFIG IFDVO


!
interface Ethernet0/0
no ip address
!
interface Ethernet0/0.804
description SWDVO - BANESTES - VLAN 804
encapsulation dot1Q 804
ip vrf forwarding IF_BANESTES
ip address 172.50.0.55 255.255.255.240
standby 1 ip 172.50.0.62
standby 1 preempt
!
interface Ethernet0/1
ip vrf forwarding IF_BANESTES
ip address 10.224.240.1 255.255.255.252
!
router eigrp 100
!
address-family ipv4 vrf IF_BANESTES autonomous-system 100
redistribute static
network 172.50.0.48 0.0.0.15
passive-interface default
no passive-interface Ethernet0/0.804
exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route vrf IF_BANESTES 0.0.0.0 0.0.0.0 172.50.0.49 name default-route-to-firewall
ip route vrf IF_BANESTES 172.16.254.87 255.255.255.255 10.224.240.2 name Autoriz_BANESTES
ip route vrf IF_BANESTES 172.16.254.88 255.255.255.255 10.224.240.2 name Autoriz_BANESTES
ip route vrf IF_BANESTES 172.16.254.180 255.255.255.255 10.224.240.2 name Autoriz_BANESTES
ip route vrf IF_BANESTES 172.16.254.184 255.255.255.255 10.224.240.2 name Autoriz_BANESTES
!

Re: redistribution EIGRP with VRF

Posted: Thu Feb 14, 2019 9:44 pm
by Uldis (UD)
Try it on vIOS or CSR routers

Re: redistribution EIGRP with VRF

Posted: Sat Feb 23, 2019 7:53 am
by NitrousOxyde
Config looks correct

Could you paste output of EIGRP topology?

Re: redistribution EIGRP with VRF

Posted: Mon Feb 25, 2019 6:02 pm
by sam1925
no default-metric?

Re: redistribution EIGRP with VRF

Posted: Fri Mar 01, 2019 3:37 am
by NitrousOxyde
sam1925 wrote:
Mon Feb 25, 2019 6:02 pm
no default-metric?
Shouldn't be an issue when redistributing static routes

Re: redistribution EIGRP with VRF

Posted: Fri Aug 02, 2019 2:15 am
by dimelo
I apologize for the delay, I was busy. Missed the metrics

Ex. Redistribute static metric 1000 1 255 255 1500

Thankys