Different CPU in GUI to the CLI

Before posting something, READ the changelog, WATCH the videos, howto and provide following:
Your install is: Bare metal, ESXi, what CPU model, RAM, HD, what EVE version you have, output of the uname -a and any other info that might help us faster.

Moderator: mike

Post Reply
mucholoco
Posts: 2
Joined: Mon May 14, 2018 10:05 am

Different CPU in GUI to the CLI

Post by mucholoco » Mon May 14, 2018 10:18 am

Hi,

Was hoping someone may be able to explain the differences in CPU usage. When looking at the CPU used I get different figures from the CLI compared to the status screen in the GUI. I am running vCPUs and VMEM for the virtual machine that is in Azure.

GUI: CPU usage - 98% Memory Usage: 96%
EVE-NG GUI status.png
root@vm-uni-eve1:~# mpstat
Linux 4.13.0-1016-azure (vm-uni-eve1) 05/14/2018 _x86_64_ (8 CPU)
10:14:00 AM CPU %usr %nice %sys %iowait %irq %soft %steal %guest %gnice %idle
10:14:00 AM all 1.23 0.00 31.86 2.02 0.00 0.05 0.00 14.56 0.00 50.27

root@vm-uni-eve1:~# free -h
total used free shared buff/cache available
Mem: 31G 29G 276M 28M 1.9G 1.2G
Swap: 0B 0B 0B

When maxed at this the Lab still runs but can be a bit slow in the GUI and CLI. I am trying to size a new VM and not sure whether this is just down to the memory as shows high in GUI and CLI, or is both the CPU and memory as is same in GUI and memory. Can anyone advise why is a difference between the CPU values from GUI and the CLI, should I work off the cli figure or that GUI figure?

Thanks
You do not have the required permissions to view the files attached to this post.

Uldis (UD)
Posts: 1438
Joined: Wed Mar 15, 2017 4:44 pm
Location: London
Contact:

Re: Different CPU in GUI to the CLI

Post by Uldis (UD) » Mon May 14, 2018 1:31 pm

you didnt say how many cores of CPU you have assigned for EVE??
and 30 Qemu nodes need CPU and ram...
Please check lab nodes calculator.... Nodes per lab...
You do not have the required permissions to view the files attached to this post.

mucholoco
Posts: 2
Joined: Mon May 14, 2018 10:05 am

Re: Different CPU in GUI to the CLI

Post by mucholoco » Mon May 14, 2018 2:46 pm

Thanks for the reply and calculator. It is setup with 8vCPUs and can see from top that all are being used by EVE. I get that 30 Qemu will need a lot of resources, I was just trying to understand the difference between GUI output and the CLI in regards to CPU. Over time the memory has dropped to below 50% (although CPU still high in GUI) and EVE GUI slugishness has gone so I guess will trust the cli output for CPU values. Thanks

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests