EVE-NG as KVM guest on AMD Ryzen 9 3900: "neither Intel VT-x or AMD-V found" warning

Moderator: mike

Post Reply
Ursl235
Posts: 3
Joined: Sun Jan 03, 2021 5:49 pm

EVE-NG as KVM guest on AMD Ryzen 9 3900: "neither Intel VT-x or AMD-V found" warning

Post by Ursl235 » Sun Jan 03, 2021 6:39 pm

Hi everyone,
I use Linux Debian on my system and KVM instead of VMware because, unlike VMware, it is free and has the same upgrade cycle as the rest of my Linux system. This is why I prefer not to remove KVM from the system. Also, I didn't install VMware as another hypervisor to avoid mess with 2 hypervisors on the same machine.

This is why I'm trying to install EVE-NG Community Edition as KVM guest and appreciate your advice on how to do it best.

My config:
AMD Ryzen 9 3900 (12 physical cores, 24 threads)
B550 based motherboard
32 GB DDR4-3600 RAM
500 GB NVME SSD
Debian 10.7 (I always use the latest stable release but installed kernel 5.9.0-0.bpo.2-amd64 x86_64 from Debian backports to enable support of new hardware on B550 motherboard)
Working KVM installed from Debian stable repository, I use VMM GUI to work with VMs

Guest config I created for EVE-NG:
16 CPU (Copy host CPU config flag set in VMM)
16 GB RAM
60 GB HDD VirtIO Disk1 (qcow2 format)
virtio NIC connected to bridge br0 on the host system

I tried both EVE-20171007.iso following links on EVE-NG.net and ubuntu-16.04.7-server-amd64.iso

When I used EVE image and installed it as VM, I got error: "No root file system. No root file system is defined. Please correct this from partitioning menu". There is no menu I can use to correct this.

This is why I tried to install "vanilla" Ubuntu 16.04 image as KVM guest following "bare metal" instructions from EVE-Comm-BOOK-1.09-2020.pdf guide. I installed it and now able to see web interface. However, I see "neither Intel VT-x or AMD-V found" warning when I boot this EVE KVM guest system.

I checked that my host system has nested virtualization enabled:
$ cat /sys/module/kvm_amd/parameters/nested
1
When I check the EVE KVM guest I see that it doesn't support AMD-V (no svm keyword in cpuinfo output):
root@eve-ng:~# cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 23
model : 1
model name : AMD EPYC Processor (with IBPB)
stepping : 2
microcode : 0x1000065
cpu MHz : 3094.186
cache size : 512 KB
physical id : 0
siblings : 1
core id : 0
cpu cores : 1
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm rep_good nopl xtopology cpuid extd_apicid tsc_known_freq pni pclmulqdq ssse3 fma cx16 sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand hypervisor lahf_lm cmp_legacy cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw topoext perfctr_core cpb ssbd ibpb vmmcall fsgsbase tsc_adjust bmi1 avx2 smep bmi2 rdseed adx smap clflushopt clwb sha_ni xsaveopt xsavec xgetbv1 xsaves arat umip
bugs : fxsave_leak sysret_ss_attrs spectre_v1 spectre_v2 spec_store_bypass
bogomips : 6188.37
TLB size : 1024 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management:
...


If I set CPU topology manually in VMM (Sockets: 16, Cores: 1, Threads: 1) the result is the same.

Appreciate your advice:
1) How to enable AMD-V in EVE-NG system installed as KVM guest?
2) Any idea on how to run EVE-NG in my case? (I can't follow obvious "install VMware" advice).

Thank you!
Last edited by Ursl235 on Sun Jan 03, 2021 7:33 pm, edited 6 times in total.

Ursl235
Posts: 3
Joined: Sun Jan 03, 2021 5:49 pm

Re: EVE-NG as KVM guest on AMD Ryzen 3900: "neither Intel VT-x or AMD-V found" warning

Post by Ursl235 » Sun Jan 03, 2021 7:19 pm

Update: I tried ready to go OVF version 2.0.3-110 which is available for download on the site. I converted vmdk to qcow2 and created a VM with that disk. The system launched and looks working (I'm able to login to web GUI and browse it) but still has the same warning (neither Intel VT-x or AMD-V found)

Uldis (UD)
Posts: 3748
Joined: Wed Mar 15, 2017 4:44 pm
Location: London
Contact:

Re: EVE-NG as KVM guest on AMD Ryzen 9 3900: "neither Intel VT-x or AMD-V found" warning

Post by Uldis (UD) » Mon Jan 04, 2021 2:35 pm

covert vmdk to qcow2 is not best choice it will work 50/50
vmdk need prepare correctly before covert

Ursl235
Posts: 3
Joined: Sun Jan 03, 2021 5:49 pm

Re: EVE-NG as KVM guest on AMD Ryzen 9 3900: "neither Intel VT-x or AMD-V found" warning

Post by Ursl235 » Mon Jan 11, 2021 10:38 pm

Thank you Uldis!
Could you pls suggest any clues on what is the best way to prepare vmdk for conversion to qcow2?
Thanks in advance!

Post Reply