Eve-NG Installation Issues

Before posting something, READ the changelog, WATCH the videos, howto and provide following:
Your install is: Bare metal, ESXi, what CPU model, RAM, HD, what EVE version you have, output of the uname -a and any other info that might help us faster.

Moderator: mike

Post Reply
bseelinger
Posts: 4
Joined: Wed Aug 12, 2020 2:16 pm

Eve-NG Installation Issues

Post by bseelinger » Wed Aug 12, 2020 2:35 pm

Greetings. I have been struggling with a bare metal installation of EVE-NG community. Nothing comes up via Internet searches for the issue I am currently having. Note that I am relatively new to Linux so please forgive my ignorance.

System Information:

AMD Ryzen 3950x CPU, 32G memory, Ubuntu 18.04.5 LTS (GNU/Linux 4.15.0-112-generic x86_64).

I have followed the EVE-NG cookbook and have successfully installed Ubuntu but when I enter the line that is supposed to install EVE-NG
I get the following message, (full output is attached):


root@eve-ng:~# DEBIAN_FRONTEND=noninteractive apt-get -y install eve-ng
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
eve-ng : PreDepends: eve-ng-guacamole (>= 2.0.3-87) but it is not going to be installed
Depends: eve-ng-guacamole but it is not going to be installed
Depends: eve-ng-qemu (>= 2.0.5-24) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

In desperation I tried to install eve-ng-guacamole with the following result:


The following packages have unmet dependencies:
eve-ng-guacamole : Depends: libwebp5 but it is not installable
Depends: libpng12-0 but it is not sources.list
Depends: libpng3 but it is not installable
Depends: libsslcommon2 but it is not installable
E: Unable to correct problems, you have held broken packages.

All of the usual software repositories appear to be defined in /etc/apt/sources.list. I also tried to re-install Ubuntu from scratch but the same error persisted.

Can anyone point me in the right direction? Any help would be appreciated.
You do not have the required permissions to view the files attached to this post.

Uldis (UD)
Posts: 3363
Joined: Wed Mar 15, 2017 4:44 pm
Location: London
Contact:

Re: Eve-NG Installation Issues

Post by Uldis (UD) » Wed Aug 12, 2020 4:33 pm

EVE Community is not for Ubuntu 18
Base OS for Bare EVE Community is 16.0.4

Thats it

bseelinger
Posts: 4
Joined: Wed Aug 12, 2020 2:16 pm

Re: Eve-NG Installation Issues

Post by bseelinger » Wed Aug 12, 2020 6:10 pm

Ah! OK - thank you very much!

Post Reply