Page 2 of 2

Re: Dell OS10 virtualization images

Posted: Sat Apr 24, 2021 12:13 am
by jvanhowell
I am new to EVE-NG. We use Dell switches, the S4000 series for our network core.
My goal is to simulate our College infrastructure, We have 4 campuses.
I have a Dell virtualization ZIP file that I downloaded before the Force10 site went away, OS10.5.2.2.

I have a couple problems:
1. My VM is installed on an ESXi 6.0.0 server, virtualization is on in the server bios and virtualization is on for the VM. I still get the message that Virtualization is off. I believe this is the reason I am unable to run Fixpermissions. I am getting the error on line 71 message.

2. When I start the DellOS10 node, after setting it up. It starts, I get the message that says it starts. Then it immediately stops.

Any idea why?

Re: Dell OS10 virtualization images

Posted: Sun Apr 25, 2021 11:37 pm
by jvanhowell
I managed to get EVE-NG installed on VirtualBox running on my local drive.
I did not get the error I was getting about Processor Virtualization, I am able to run the fixpermissions routine.
After uploading the Dell OS10.5.2.2.vmdk's that I have, and fixing permissions they are all working.

Re: Dell OS10 virtualization images

Posted: Mon Apr 26, 2021 1:02 pm
by Uldis (UD)
VirtualBox is not supported for EVE !!!

https://www.eve-ng.net/index.php/docume ... quirement/

Re: Dell OS10 virtualization images

Posted: Tue Apr 27, 2021 9:20 pm
by jvanhowell
I have a Dell OS10.5.2.2 zip file. It has multiple images.
I am using the s4000 image. I had no problems after I realized it does not load nearly as fast as on the switch hardware. I just had to wait for it to do its thing and stop hitting enter to see if it is working.

Once I booted into OS10 the first command I run (not in config mode) ZTD Cancel. This cancels Zero Touch Deployment. That sometimes interfered with the OS operation. It would lock the config.

Hope this helps.

I have the same problem with Ethernet Ports on this image. The S4000 switch registers as an S4048, 48-10Gig ports and 6-40Gig ports.

Status : up
Down Reason : unknown
Digital Optical Monitoring : disable
System Location LED : off
Required Type : S4048
Current Type : S4048
Hardware Revision :
Software Version : 10.5.2.2
Physical Ports : 48x10GbE, 6x40GbE

I can only get 25 ports plus management port to show up in the Node.

Re: Dell OS10 virtualization images

Posted: Wed Apr 28, 2021 12:55 pm
by Uldis (UD)
and 25 ports is more than enough

Re: Dell OS10 virtualization images

Posted: Wed Apr 28, 2021 5:26 pm
by jvanhowell
What you are saying is that 25 ports is all that is allowed in EVE-NG?
I will need to rewrite my configurations to stay within the 25 port limit?

Re: Dell OS10 virtualization images

Posted: Wed Apr 28, 2021 7:35 pm
by Uldis (UD)
It is not EVE limit but Virtual VM of Dell or other vendors, like cisco vIOS L2 for example supports up to 16 ports, but Arista VEOS up to 25 ports