Layer 2 Switching issues in EVE-NG

Before posting something, READ the changelog, WATCH the videos, howto and provide following:
Your install is: Bare metal, ESXi, what CPU model, RAM, HD, what EVE version you have, output of the uname -a and any other info that might help us faster.

Moderator: mike

Post Reply
IT-Biscuit
Posts: 2
Joined: Sun Aug 11, 2019 2:04 pm

Layer 2 Switching issues in EVE-NG

Post by IT-Biscuit » Sun Aug 11, 2019 2:30 pm

Hardware:
  • Desktop
    Intel(R) Core(TM) i5-7500 CPU @ 3.40 GHz 3.41 GHz
    Windows 10
    24 GB RAM
    1 TB HDD
Issue:
I'm getting very scetchy results when attempting to perform layer 2 switching on my Cisco devices. I haven't tried with anything else yet.
I am attempting to configure a Spanning Tree / HSRP setup with a server on the access layer. I also tried with a vPC but am yielding the same results. In short, the mac-address table on my switches remains blank. I disabled ip routing and ensured the interfaces were up and that the vlans were properly tagged on each port but whenever I try to ping out, it doesnt even seem to try to leave the host machine (the VPC or server). I at first thought the issue was isolated to the VPC as I did for a short time manage to get HSRP / Spanning Tree to work and I even managed to get the core switches to ping eachother on their assigned VLAN IP. Saved the configs and stopping and restarting each node, they no longer can talk..

I decided maybe it was just an issue with my configs but I tried a similar setup in packet-tracer using layer 3 switches and it worked fine.

The switches are all L3 switches - using Cisco 3725's.

Here is my topology:
(ignore the two routers at the top, I removed the configs for those and decomissioned them from the setup, I just haven't updated the physical topology on those yet...all of the issues are happening L2)
eve-topology.png
Here are my configs:

VPCS
VPCS> ip 10.10.10.11/24 10.10.10.1
Checking for duplicate address...
PC1 : 10.10.10.11 255.255.255.0 gateway 10.10.10.1

VPCS> ping 10.10.10.1

host (10.10.10.1) not reachable

VPCS> ping 10.10.10.2

host (10.10.10.2) not reachable
Austin-CL-SW1:

Austin-CL-SW1#show run
Building configuration...

Current configuration : 1913 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Austin-CL-SW1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree vlan 10 priority 8192
spanning-tree vlan 20 priority 16384
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
switchport mode trunk
!
interface FastEthernet1/1
switchport mode trunk
!
interface FastEthernet1/2
switchport mode trunk
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
switchport access vlan 10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface FastEthernet2/0
!
interface FastEthernet2/1
!
interface FastEthernet2/2
!
interface FastEthernet2/3
!
interface FastEthernet2/4
!
interface FastEthernet2/5
!
interface FastEthernet2/6
!
interface FastEthernet2/7
!
interface FastEthernet2/8
!
interface FastEthernet2/9
!
interface FastEthernet2/10
!
interface FastEthernet2/11
!
interface FastEthernet2/12
!
interface FastEthernet2/13
!
interface FastEthernet2/14
!
interface FastEthernet2/15
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 10.10.10.2 255.255.255.0
!
interface Vlan20
ip address 10.10.20.2 255.255.255.0
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end


Austin-CL-SW1#show vlan-switch

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa1/3, Fa1/4, Fa1/5, Fa1/6
Fa1/7, Fa1/8, Fa1/9, Fa1/11
Fa1/12, Fa1/13, Fa1/14, Fa1/15
Fa2/0, Fa2/1, Fa2/2, Fa2/3
Fa2/4, Fa2/5, Fa2/6, Fa2/7
Fa2/8, Fa2/9, Fa2/10, Fa2/11
Fa2/12, Fa2/13, Fa2/14, Fa2/15
10 Mgmt-Servers active Fa1/10
20 Data-Store-Servers active
30 PC's active
99 Native active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 1002 1003
10 enet 100010 1500 - - - - - 0 0

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
20 enet 100020 1500 - - - - - 0 0
30 enet 100030 1500 - - - - - 0 0
99 enet 100099 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 1 1003
1003 tr 101003 1500 1005 0 - - srb 1 1002
1004 fdnet 101004 1500 - - 1 ibm - 0 0
1005 trnet 101005 1500 - - 1 ibm - 0 0


Austin-CL-SW1#show int trunk

Port Mode Encapsulation Status Native vlan
Fa1/0 on 802.1q trunking 1
Fa1/1 on 802.1q trunking 1
Fa1/2 on 802.1q trunking 1

Port Vlans allowed on trunk
Fa1/0 1-4094
Fa1/1 1-4094
Fa1/2 1-4094

Port Vlans allowed and active in management domain
Fa1/0 1,10,20,30,99
Fa1/1 1,10,20,30,99
Fa1/2 1,10,20,30,99

Port Vlans in spanning tree forwarding state and not pruned
Fa1/0 1,10,20,30,99
Fa1/1 10,20
Fa1/2 1,10,20,30,99

Austin-CL-SW2
Austin-CL-SW2#show run
Building configuration...

Current configuration : 1886 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Austin-CL-SW2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree vlan 10 priority 16384
spanning-tree vlan 20 priority 8192
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
switchport mode trunk
!
interface FastEthernet1/1
switchport mode trunk
!
interface FastEthernet1/2
switchport mode trunk
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface FastEthernet2/0
!
interface FastEthernet2/1
!
interface FastEthernet2/2
!
interface FastEthernet2/3
!
interface FastEthernet2/4
!
interface FastEthernet2/5
!
interface FastEthernet2/6
!
interface FastEthernet2/7
!
interface FastEthernet2/8
!
interface FastEthernet2/9
!
interface FastEthernet2/10
!
interface FastEthernet2/11
!
interface FastEthernet2/12
!
interface FastEthernet2/13
!
interface FastEthernet2/14
!
interface FastEthernet2/15
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 10.10.10.3 255.255.255.0
!
interface Vlan20
ip address 10.10.20.3 255.255.255.0
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

Austin-CL-SW2#show vlan-switch

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa1/3, Fa1/4, Fa1/5, Fa1/6
Fa1/7, Fa1/8, Fa1/9, Fa1/10
Fa1/11, Fa1/12, Fa1/13, Fa1/14
Fa1/15, Fa2/0, Fa2/1, Fa2/2
Fa2/3, Fa2/4, Fa2/5, Fa2/6
Fa2/7, Fa2/8, Fa2/9, Fa2/10
Fa2/11, Fa2/12, Fa2/13, Fa2/14
Fa2/15
10 Mgmt-Servers active
20 Data-Store-Servers active
30 PC's active
99 Native active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 1002 1003

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
10 enet 100010 1500 - - - - - 0 0
20 enet 100020 1500 - - - - - 0 0
30 enet 100030 1500 - - - - - 0 0
99 enet 100099 1500 - - - - - 0 0
1002 fddi 101002 1500 - 0 - - - 1 1003
1003 tr 101003 1500 1005 0 - - srb 1 1002
1004 fdnet 101004 1500 - - 1 ibm - 0 0
1005 trnet 101005 1500 - - 1 ibm - 0 0



Austin-CL-SW2#show int trunk

Port Mode Encapsulation Status Native vlan
Fa1/0 on 802.1q trunking 1
Fa1/1 on 802.1q trunking 1
Fa1/2 on 802.1q trunking 1

Port Vlans allowed on trunk
Fa1/0 1-4094
Fa1/1 1-4094
Fa1/2 1-4094

Port Vlans allowed and active in management domain
Fa1/0 1,10,20,30,99
Fa1/1 1,10,20,30,99
Fa1/2 1,10,20,30,99

Port Vlans in spanning tree forwarding state and not pruned
Fa1/0 10,20
Fa1/1 1,10,20,30,99
Fa1/2 10,20
Austin-AL-SW3
Austin-AL-SW3#show run
Building configuration...

Current configuration : 1800 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Austin-AL-SW3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip routing
no ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
switchport mode trunk
!
interface FastEthernet1/1
switchport mode trunk
!
interface FastEthernet1/2
switchport mode trunk
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
switchport access vlan 10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface FastEthernet2/0
!
interface FastEthernet2/1
!
interface FastEthernet2/2
!
interface FastEthernet2/3
!
interface FastEthernet2/4
!
interface FastEthernet2/5
!
interface FastEthernet2/6
!
interface FastEthernet2/7
!
interface FastEthernet2/8
!
interface FastEthernet2/9
!
interface FastEthernet2/10
!
interface FastEthernet2/11
!
interface FastEthernet2/12
!
interface FastEthernet2/13
!
interface FastEthernet2/14
!
interface FastEthernet2/15
!
interface Vlan1
no ip address
no ip route-cache
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

Austin-AL-SW3#show vlan-switch

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa1/3, Fa1/4, Fa1/5, Fa1/6
Fa1/7, Fa1/8, Fa1/9, Fa1/11
Fa1/12, Fa1/13, Fa1/14, Fa1/15
Fa2/0, Fa2/1, Fa2/2, Fa2/3
Fa2/4, Fa2/5, Fa2/6, Fa2/7
Fa2/8, Fa2/9, Fa2/10, Fa2/11
Fa2/12, Fa2/13, Fa2/14, Fa2/15
10 Mgmt-Servers active Fa1/10
20 Data-Store-Servers active
30 PC's active
99 Native active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 1002 1003
10 enet 100010 1500 - - - - - 0 0

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
20 enet 100020 1500 - - - - - 0 0
30 enet 100030 1500 - - - - - 0 0
99 enet 100099 1500 - - - - - 0 0
1002 fddi 101002 1500 - 0 - - - 1 1003
1003 tr 101003 1500 1005 0 - - srb 1 1002
1004 fdnet 101004 1500 - - 1 ibm - 0 0
1005 trnet 101005 1500 - - 1 ibm - 0 0
Austin-AL-SW3#
Austin-AL-SW3#
Austin-AL-SW3#show interface trunk

Port Mode Encapsulation Status Native vlan
Fa1/0 on 802.1q trunking 1
Fa1/1 on 802.1q trunking 1
Fa1/2 on 802.1q trunking 1

Port Vlans allowed on trunk
Fa1/0 1-4094
Fa1/1 1-4094
Fa1/2 1-4094

Port Vlans allowed and active in management domain
Fa1/0 1,10,20,30,99
Fa1/1 1,10,20,30,99
Fa1/2 1,10,20,30,99

Port Vlans in spanning tree forwarding state and not pruned
Fa1/0 1,10,20,30,99
Fa1/1 1,20,30,99
Fa1/2 1,10,30,99
Austin-AL-SW4
AUS-AL-SW4#show run
Building configuration...

Current configuration : 1770 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname AUS-AL-SW4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip routing
no ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
switchport mode trunk
!
interface FastEthernet1/1
switchport mode trunk
!
interface FastEthernet1/2
switchport mode trunk
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface FastEthernet2/0
!
interface FastEthernet2/1
!
interface FastEthernet2/2
!
interface FastEthernet2/3
!
interface FastEthernet2/4
!
interface FastEthernet2/5
!
interface FastEthernet2/6
!
interface FastEthernet2/7
!
interface FastEthernet2/8
!
interface FastEthernet2/9
!
interface FastEthernet2/10
!
interface FastEthernet2/11
!
interface FastEthernet2/12
!
interface FastEthernet2/13
!
interface FastEthernet2/14
!
interface FastEthernet2/15
!
interface Vlan1
no ip address
no ip route-cache
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

AUS-AL-SW4#show vlan-switch

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa1/3, Fa1/4, Fa1/5, Fa1/6
Fa1/7, Fa1/8, Fa1/9, Fa1/10
Fa1/11, Fa1/12, Fa1/13, Fa1/14
Fa1/15, Fa2/0, Fa2/1, Fa2/2
Fa2/3, Fa2/4, Fa2/5, Fa2/6
Fa2/7, Fa2/8, Fa2/9, Fa2/10
Fa2/11, Fa2/12, Fa2/13, Fa2/14
Fa2/15
10 Mgmt-Servers active
20 Data-Store-Servers active
30 PC's active
99 Native active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 1002 1003

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
10 enet 100010 1500 - - - - - 0 0
20 enet 100020 1500 - - - - - 0 0
30 enet 100030 1500 - - - - - 0 0
99 enet 100099 1500 - - - - - 0 0
1002 fddi 101002 1500 - 0 - - - 1 1003
1003 tr 101003 1500 1005 0 - - srb 1 1002
1004 fdnet 101004 1500 - - 1 ibm - 0 0
1005 trnet 101005 1500 - - 1 ibm - 0 0
AUS-AL-SW4#
AUS-AL-SW4#
AUS-AL-SW4#
AUS-AL-SW4#show interface trunk

Port Mode Encapsulation Status Native vlan
Fa1/0 on 802.1q trunking 1
Fa1/1 on 802.1q trunking 1
Fa1/2 on 802.1q trunking 1

Port Vlans allowed on trunk
Fa1/0 1-4094
Fa1/1 1-4094
Fa1/2 1-4094

Port Vlans allowed and active in management domain
Fa1/0 1,10,20,30,99
Fa1/1 1,10,20,30,99
Fa1/2 1,10,20,30,99

Port Vlans in spanning tree forwarding state and not pruned
Fa1/0 1,30,99
Fa1/1 1,10,30,99
Fa1/2 1,20,30,99
You do not have the required permissions to view the files attached to this post.

Uldis (UD)
Posts: 2566
Joined: Wed Mar 15, 2017 4:44 pm
Location: London
Contact:

Re: Layer 2 Switching issues in EVE-NG

Post by Uldis (UD) » Sun Aug 11, 2019 4:34 pm

better use IOL L2 and L3 nodes.. :)

IT-Biscuit
Posts: 2
Joined: Sun Aug 11, 2019 2:04 pm

Re: Layer 2 Switching issues in EVE-NG

Post by IT-Biscuit » Sun Aug 11, 2019 5:38 pm

Super sorry as I am still very new to Eve and virtualization. Can you recommend specifically which nodes I should use? I'm uncertain which IOL nodes are specifically for L2 and L3 and what is supported for Eve-NG

Uldis (UD)
Posts: 2566
Joined: Wed Mar 15, 2017 4:44 pm
Location: London
Contact:

Re: Layer 2 Switching issues in EVE-NG

Post by Uldis (UD) » Sun Aug 11, 2019 8:27 pm

come to eve live chat to talk
https://www.eve-ng.net/live-helpdesk
use your gmail account or create new to join

Uldis (UD)
Posts: 2566
Joined: Wed Mar 15, 2017 4:44 pm
Location: London
Contact:

Re: Layer 2 Switching issues in EVE-NG

Post by Uldis (UD) » Sun Aug 11, 2019 8:29 pm

first issue, do not use x2 16 port cards just one !!!
in your lab you neednot 32 ports..
and dynamips nodes making serious issues with 32 ports
use 16 only (1 card)

Post Reply