Bare installation no external network reachability

Before posting something, READ the changelog, WATCH the videos, howto and provide following:
Your install is: Bare metal, ESXi, what CPU model, RAM, HD, what EVE version you have, output of the uname -a and any other info that might help us faster.

Moderator: mike

Post Reply
DL1WW
Posts: 8
Joined: Wed Nov 06, 2019 11:12 pm

Bare installation no external network reachability

Post by DL1WW » Wed Nov 06, 2019 11:24 pm

Hi,

Currently I performing the bare installation following the documentation.
All works fine until the point after changing the interface names to eth0.

After the reboot, the server doesn‘t find the dhcp server.
If i change the interface configuration to static ip, the new static IP adress is reachable for ping only locally but not from
external.
Further it is not possible to ping to an external host.

All troubleshooting output shows an active interface with the correct ip addressing.

I‘m a little bit confused now what‘s going wrong.
It would be great if I could get a little help with my issue.

Thanks!
Jens

philldm
Posts: 5
Joined: Tue Jul 24, 2018 3:30 pm

Re: Bare installation no external network reachability

Post by philldm » Thu Nov 07, 2019 8:45 am

Hello. I had the same problem. My solution during bare metal installation was: firstly I've done step 2.10, then secondly step 2.9. That solved my problem. Try this, maybe it will help.

DL1WW
Posts: 8
Joined: Wed Nov 06, 2019 11:12 pm

Re: Bare installation no external network reachability

Post by DL1WW » Thu Nov 07, 2019 9:57 am

I've read a related posting (yours?) with this recommendation and I've tried this today morning.
But the result was the same.

All seems to be ok in the output of ifconfig, netstat -rn, netstat -i.

The interface eth0 holds its new name and if choose a static configuration, the IP address of the interface is pingable.... but only from local.
If I configure eth0 with DHCP instead, the DHCP communication fails.

It's really strange.

DL1WW
Posts: 8
Joined: Wed Nov 06, 2019 11:12 pm

Re: Bare installation no external network reachability

Post by DL1WW » Thu Nov 07, 2019 10:23 am

Oh!

I have just seen that the order of the configuration steps has been changed exactly at this point during the last hours.

DL1WW
Posts: 8
Joined: Wed Nov 06, 2019 11:12 pm

Re: Bare installation no external network reachability

Post by DL1WW » Thu Nov 07, 2019 10:47 am

Uhmm..

After a repeat of the full Ubuntu installation following the now corrected step order..... the same problem occurs .... DHCP communication fails and static IP configuration seems to produce a proper eth0 interface but it is not able to communicate.

I'm a bit helpless now. :-(

DL1WW
Posts: 8
Joined: Wed Nov 06, 2019 11:12 pm

Re: Bare installation no external network reachability

Post by DL1WW » Thu Nov 07, 2019 3:06 pm

New status:

Before I changed the interface naming followed by the grub-configuration part, the netstat -i command shows for the enp0s31f6 interface flags BMRU.

After the ifname-change to eth0, update-grub and reboot, the netstat -i command shows for eth0 flags BMU ..... The "Running"-Flag is now missing!
A reason for this could be a driver problem.
But why no driver problem occurred before?

Uldis (UD)
Posts: 2557
Joined: Wed Mar 15, 2017 4:44 pm
Location: London
Contact:

Re: Bare installation no external network reachability

Post by Uldis (UD) » Fri Nov 08, 2019 4:58 pm

Check if your driver is Broadcom, then you can follow eve cookbook bare install step 43

DL1WW
Posts: 8
Joined: Wed Nov 06, 2019 11:12 pm

Re: Bare installation no external network reachability

Post by DL1WW » Sat Nov 09, 2019 9:51 pm

I've two NICs in my server...

1x Intel I219-V (1xGE) with driver E1000E
1x Intel I340-T4 (4xGE) with driver IGB

Should I change to original Broadcom NICs?

The other hardware on the machine:

Intel Core i9-7920X, 12x 2,9 GHz, 16,5 MB L3 Cache, So. 2066
ASUS Prime X299-A, X299, So. 2066
8x 16GB DDR4-2666, Corsair Vengeance LPX black, Rev S (128 GB)

DL1WW
Posts: 8
Joined: Wed Nov 06, 2019 11:12 pm

Re: Bare installation no external network reachability

Post by DL1WW » Sat Nov 09, 2019 10:31 pm

No matter which way I go....
I ran in the same problem with every try.

I'm "a little bit" frustrated.
I think I have to move back to GNS3 if I don't find a solution immediately.

DL1WW
Posts: 8
Joined: Wed Nov 06, 2019 11:12 pm

Re: Bare installation no external network reachability

Post by DL1WW » Sat Nov 09, 2019 11:20 pm

Problem solved with great and quick support from the Live Helpdesk!

After I've stated that I'm using 5 physical GE ports I get the following advice:

changing kernel could change nic order
so try to move your network plug
check with ethtool eth0 if link is up

And exactly this was the problem!

After moving the plug from port to port, the last one cames up and all is fine now.

I'm so happy! :-)

Post Reply