Failed to Connect to Server on Google Cloud

Before posting something, READ the changelog, WATCH the videos, howto and provide following:
Your install is: Bare metal, ESXi, what CPU model, RAM, HD, what EVE version you have, output of the uname -a and any other info that might help us faster.

Moderator: mike

Post Reply
crushfactor
Posts: 1
Joined: Sun Feb 24, 2019 4:01 pm

Failed to Connect to Server on Google Cloud

Post by crushfactor » Sun Feb 24, 2019 4:46 pm

I have eve-ng running on Ubuntu 16.04 as a Google Cloud VM instance.

However VNC says failed to connect to server when I try to use Windows/Linux nodes.

ON starting Linux node:
root@final:/opt/unetlab/data/Logs# Feb 24 16:44:16 final ovs-vsctl: ovs|00001|vsctl|INFO|Called as ovs-vsctl del-port vunl0_2_0
Feb 24 16:44:16 final ovs-vsctl: ovs|00002|db_ctl_base|ERR|no port named vunl0_2_0
Feb 24 16:44:16 final kernel: [ 569.908672] pnet1: port 1(vunl0_2_0) entered blocking state
Feb 24 16:44:16 final kernel: [ 569.908676] pnet1: port 1(vunl0_2_0) entered forwarding state
Feb 24 16:44:16 final kernel: [ 569.909164] pnet1: port 1(vunl0_2_0) entered disabled state
Feb 24 16:44:16 final kernel: [ 569.912563] device vunl0_2_0 left promiscuous mode
Feb 24 16:44:16 final kernel: [ 569.912567] pnet1: port 1(vunl0_2_0) entered disabled state
Feb 24 16:44:16 final kernel: [ 569.980674] pnet1: port 1(vunl0_2_0) entered blocking state
Feb 24 16:44:16 final kernel: [ 569.980678] pnet1: port 1(vunl0_2_0) entered disabled state
Feb 24 16:44:16 final kernel: [ 569.980799] device vunl0_2_0 entered promiscuous mode
Feb 24 16:44:16 final kernel: [ 569.980847] pnet1: port 1(vunl0_2_0) entered blocking state
Feb 24 16:44:16 final kernel: [ 569.980849] pnet1: port 1(vunl0_2_0) entered forwarding state
Feb 24 16:44:18 final ntpd[4253]: Listen normally on 19 pnet1 192.168.239.1:123
Feb 24 16:44:18 final ntpd[4253]: Listen normally on 20 pnet1 [fe80::e886:a9ff:fedc:6871%4]:123
Feb 24 16:44:18 final ntpd[4253]: new interface(s) found: waking up resolver


Config:
n1-standard-4 (4 vCPUs, 15 GB memory)
Intel Skylake

Let me know if you need any other information.

Sipart
Posts: 55
Joined: Sun Mar 19, 2017 9:20 pm

Re: Failed to Connect to Server on Google Cloud

Post by Sipart » Sat Mar 16, 2019 1:31 pm

You can ssh to other nodes running in your lab? Just vnc that doesn't work to Win and Linux devices?

Your GCP firewall rules have been set in what way to allow this?

Another question - did you setup your GCP Ubuntu server as a custom image so it supports nested virtualization?

Cheers

Post Reply